1. Geosi VERM
  2. Benutzeroberfläche
  3. Netzausgleich
  4. Allgemeine Hinweise
    1. Voraussetzungen
    2. Besonderheiten
      1. Filter Dialog
  5. Arbeitsbereich
    1. Gesamtansicht
    2. Menü
    3. Dokument
    4. Willkommen Fenster HTML
    5. Willkommen Fenster klassisch
    6. Projektsbereich (Datenverwalter)
    7. Checkliste
      1. Checkliste bearbeiten
    8. Grafik
      1. Punkte
      2. Linien/Zeichenfunktionen
      3. Bemaßung
      4. Layereinstellungen
      5. DXF-Import
    9. Protokollbereich
      1. Ereignisanzeige
      2. Notizblock
      3. Protokoll
        1. Protokoll einrichten
        2. Word-Protokoll
  6. Daten
    1. Datenmodelle im Überblick
    2. Messdaten suchen
    3. Import Allgemein
      1. Daten übernehmen
      2. Bei Übernahme Prüfen
    4. Punkte
      1. Neuer Punkt
      2. Neue Punkte
        1. Vorschlagswerte
      3. Punktkollision
        1. Punktkollision einfach
        2. Punktkollision mehrfach
      4. Liste
      5. Umnummerieren
        1. Kollision
      6. Ändern
      7. Löschen
      8. Runden
      9. Papierkorb
      10. Mehrfachpunkt-Bereinigung
        1. Einzelauswahl
        2. Mehrfachauswahl
      11. Attributvoreinstellungen
      12. Eigenschaften
      13. History
      14. Koordinaten bezüglich Meridianstreifen testen
      15. Import
        1. Koordinaten Importieren
        2. Methoden Import Ascii
        3. Editor für Steuerfile
        4. Umsetztabellen-Editor
      16. Export
        1. ASCII
        2. DXF
          1. Umsetztabellen Editor
            1. Punkte
            2. Linien
            3. Netzbild
            4. Profil
        3. SQD-Umsetzer
        4. Export Tachymeter
      17. Suchen
        1. Suchen über Koordinaten
        2. Suchen über Messdaten
        3. Suchen über Bezeichnung, Code
        4. Suchergebnis
    5. Tachymeterdaten
      1. Liste
      2. Eigenschaften
        1. Exzentercodes
      3. Prüfen
      4. Nicht berechnete Punkte finden
      5. Eingabe
        1. Standpunkt auswählen
        2. Satz auswählen
        3. Werte Standpunkt, Satz
        4. Vorschlagswerte Zielpunkte
        5. Eingabe Zielpunkte
      6. Import
        1. Importieren
          1. Definition Maske Zeiss
          2. Definition Codeblöcke Leica
          3. Definition Label Geodimeter
        2. Messdaten auswählen
        3. Standpunkte/Zielpunkte umbenennen
        4. Einleseoptionen
        5. Zielpunkt-Kollision
      7. Zielpunkte ändern
        1. Auswahl
        2. Werte
    6. Nivellement
      1. Nivellement Daten
      2. Liste
      3. Nivellementdaten eingeben
      4. Eigenschaften
      5. Importieren
    7. GPS
      1. Eigenschaften GPS Vektoren
      2. Eigenschaften für WGS 84 Punkt
      3. GPS Antennenhöhe korrigieren
      4. GPS Basislinien Importieren
      5. WGS Punkte Kollision
      6. WGS Trafo Kollision
      7. Transformationen
        1. Eigenschaften Globale Transformation
        2. Eigenschaften Anfelderung Lage
          1. Parameter Anfelderung Lage
        3. Eigenschaften Anfelderung Höhe
          1. Parameter Anfelderung Höhe
        4. Passpunkte für Anfelderung
    8. Flächen
      1. Liste
      2. Eigenschaften
    9. KVZ
      1. Koordinatenverzeichnis erstellen
      2. KVZ: ASCII-File
      3. Netzbild
      4. KVZ Protokoll
    10. Liniencodierung
      1. Verwaltung
      2. DXF Export Assistent für Linien
        1. DXF Export: Snap
    11. Datenbank
      1. Benutzerverwaltung
      2. Projektverwaltung
      3. Punktverwaltung
      4. Verwaltung GPS-Vektoren
      5. DB Login
    12. GIS
      1. Festpunkte
        1. Import
          1. Layerauswahl
          2. Auswahl Punkte
          3. Filter
        2. Export
          1. Layerauswahl
          2. Auswahl Punkte
          3. Punktkollision
        3. Löschen
          1. Layerauswahl
          2. Auswahl Punkte
          3. Filter
        4. Übernahme alte DB
      2. Projekte
        1. Projektgrenzen manuell ändern
        2. Projekte aktualisieren
  7. Berechnungen
    1. Polygonzug Auswahl
      1. Polygonzüge / Höhenzüge
    2. Orientierungsberechnung
    3. Freie Stationierung
    4. Polarpunktberechnung / Höhenberechnung
    5. Überbestimmte Exzenterberechnung
    6. Höhenableitung
    7. Absteckelemente Auswahl
    8. Absteckelemente
    9. Koordinaten -> Tachymeterdaten
    10. Vorwärtsschnitt
    11. Vorwärtsschnitt manuell
    12. Rückwärtsschnitt
    13. Nivellement
    14. Bogenschnitt
    15. Geradenschnitt
    16. Lotfußpunkt
    17. Orthogonalpunktberechnung
    18. Fortgesetzte Orthogonalpunktberechnung fliegend
    19. Fortgesetzte Orthogonalpunktberechnung geschlossen
    20. Flächenberechnung
    21. Dreiecksteilung
    22. Trapezteilung
    23. Gerade durch n Punkte
    24. Dreiecksassistent
    25. Kreisaufgaben
      1. Kreisbogen Zwischenpunkte einrechnen
      2. Schnitt Kreis – Gerade
      3. Schnitt Kreis – Kreis
      4. Tangente an Kreis
      5. Kreisbogen – Einrechnung
      6. Kreisassistent
    26. Transformation
      1. Helmert, Affin, Flächentreu
      2. Meridianstreifen Umrechnung
        1. 2D im selben System
        2. 2D über NTv2 Grid
        3. 3D in fremdes System über GPS
      3. Projektionssystem > Geografische Koordinaten
      4. Geografische Koordinaten > Projektionssystem
    27. Trassierung
      1. Trasse definieren
      2. Achskleinpunkte
      3. Lotfusspunkte auf Trasse
    28. GPS
      1. GPS-Polarpunktberechnung: Auswahl
      2. Rererence Frame Umrechnung
      3. GPS-Polarpunktberechnung: Berechung
      4. Koordinaten aus GPS Vektoren
        1. Referenzstation
        2. Berechnete WGS 84 Punkte
      5. WGS 84 -> Projektionssystem
        1. Berechnung Parameter
        2. Auswahl Parameter
        3. Ergebnis
      6. Projektionssystem -> GPS
        1. Auswahl
        2. Berechnung
    29. Profil
      1. Profil – Fläche
      2. Profil
      3. Profil exportieren
    30. Satzausgleich
    31. Deformation
      1. Definition der Deformationspunke
      2. Ausgabe der Deformationsliste
      3. DXF-Export
        1. Programmablauf
          1. Auswahl Deformationstyp
          2. Auswahl Daten
          3. Auswahl der Darstellungsparameter
          4. Feinauswahl Daten, Darstellung
          5. Deformation speichern
        2. Parameter für DXF Export
    32. Kanalmessstab
    33. 3D-Berechnungen
      1. Kreis durch n Punkte 3D
      2. Ebene durch n Punkte 3D
      3. Punktabstände von einer 3D-Ebene
      4. Gerade durch n Punkte 3D
      5. Punktabstände von einer 3D-Geraden
    34. Exzenterstab
      1. Exzenterstab definieren
  8. Einstellungen / Optionen
    1. Kollision
    2. KG-Auswahl
    3. Layer definieren
    4. Symbolzuordnung
    5. Darstellung der Bemaßung
    6. Globale Optionen
      1. Ellipsoide
      2. Meridianstreifen Systeme
      3. Höhensysteme
      4. Messgeräte
      5. Stabilisierungen
      6. WGS Transformationen
    7. Lokale Optionen
    8. Projekt
      1. Eigenschaften Projekt Allgemein
      2. Epochenverwaltung
      3. Projekt
      4. Nachkommastellen/Genauigkeiten
      5. Projektionssystem und Reduktionen
      6. Toleranzen
      7. Grafik
  9. Anhang
    1. Datenstruktur Geosi-Projekt
    2. Datenstruktur Datenbank Punktverwaltung
    3. Protokoll anpassen
    4. Pfade und Dateien
    5. GPS-Reference Frame
  10. Maintenance
  11. Geosi NETZ
  12. Geosi NUM

9.3.Anhang - Protokoll anpassen

Das Aussehen des Protokolls (Word oder Rich-Text) wird durch folgende ASCII-Dateien gesteuert:

  • Geosi60.gpe
  • Geosi60.gpu

Das „gpe-File“ enthält die originalen Protokollvorlagen und darf nicht verändert werden. Es wird bei jedem Geosi-Update überschrieben.

Das „gpu-File“ dient zum benutzerdefinierten Anpassen des Protokolls und wird nicht überschrieben.

Beide Dateien sind im globalen Systemverzeichnis zu finden.

Wurden diese Datei geändert, so können über Menü: „Optionen/Protokollvorlage neu laden“ die veränderten Dateien ins Geosi eingelesen werden. Lästige Neustarts des Programms sind dann nicht notwendig. Schon bei der nächsten Berechnung wird das veränderte Protokoll verwendet.

Ändern von Textbausteinen

  • Den gewünschten Baustein im gpe-file suchen.
  • Den Baustein ins gpu-file kopieren
  • Änderungen durchführen

Aufbau des Protokolls

  • Ein Textbaustein ist jeweils von einer Kennung und einem Ende eingeschlossen:

#LISTE
Hier wird Protokoll geschrieben
#ENDE

  • Durch geschwungene Klammern können Formatparameter eingegeben werden:

{Überschrift1} … Formatvorlage Text (nur nach Kennung des Textbausteins)
{R010} … Formatierung Variable (nur nach Variable)

  • Variablen sind durch eckige Klammerung erkennbar:

[Bez] [y]

 

Übersicht:

#IRGENDWAS Kennung: Kennzeichnung eines Textbausteins (darf nicht geändert werden)
<Tabelle> Typ des Bausteins: Überschrift, Text, Tabelle; kann nicht geändert werden
{Überschrift 1} Schriftstil, direkt nach Kennung; Schriftstil muss in der Formatvorlage des Vorlagen-Dokumentes vorkommen
[Variable] Variable (wird durch wert ersetzt)
{L020} Formatparameter, direkt nach Variable; L… linksbündig, R … rechtsbündig, Z … zentriert, Längenangabe muss dreistellig sein.
[*L] Einheiten: (sind von den Einstellung im Programm abhängig)
L… Länge, W … Winkel, F … Fläche, G …Geographische Koordinaten,
T …Temperatur, P …Luftdruck
l… Längen Untereinheit , w…Winkel Untereinheit, p…ppm
{NOBREAK} kann nur am Zeilenende stehen: verhindert Zeilenumbruch am Zeilenende (Zum Zusammenbau einer Zeile aus mehreren Textbausteinen)
{DATA}{Schrift 2} Tabelle: Kennzeichnung der Datenzeile (Text nach Kennung = Kopfzeile)

Beispiel:

* [bez] Punktbezeichung
* [y] y-Koordinate (Rechtswert)
* [x] x-Koordinate (Hochwert)
* [h] Höhe
* <Tabelle>
#LISTE{TabHead}
Punkt                   Y[*L]{R005}        X[*L]{R005}     H[*L]{R005}
{DATA}{TabLine}
[bez]{L016}  [y]{R012} [x]{R013} [h]{R010}
#END

Erklärung:

* [bez] Punktbezeichung … Beschreibung der versorgten Variablen

* <Tabelle> … Der Textbaustein ist eine Tabelle

#LISTE{TabHead} … Textbaustein „#LISTE“, Formatvorlage Schrift: „TabHead“

Punkt …                   Y[*L]{R005}        X[*L]{R005}     H[*L]{R005} … Überschrift der    Tabelle

[*L]{R005} … [ Längeneinheit], rechtsbündig, mit Leerzeichen auf 5 Stellen aufgefüllt

{DATA}{TabLine} … „DATA“ Trennung zwischen Tabellenüberschrift und Zeile, „TabLine“ Format Zeile

[bez]{L016}  [y]{R012} [x]{R013} [h]{R010} … Formatierung Zeile

[bez]{L016} … Bezeichnung linksbündig, 16 Zeichen

[y]{R012} … y-Koordinate, rechtsbündig, 12 Zeichen

#END … Ende Textbaustein

Geosi-Protokoll

Die Standardeinstellungen für Kopf- und Fußzeile können im gpu-File durchgeführt werden (für normales Protokoll und KVZ). Dazu sind lediglich die Protokollbereiche „#PROT_KOPFZEILE“ und „#PROT_FUSSZEILE“, bzw. „#PROT_KVZ_KOPFZEILE“ und „#PROT_KVZ_FUSSZEILE“ in aus dem gpe-File in das gpu-File zu kopieren und dort zu verändern (siehe auch „Protokoll anpassen“).

Für das aktuelle Projekt können Kopf- und Fußzeile auch im Menüpunkt „Datei, Protokoll einrichten …“ geändert werden (Siehe Beschreibung des Datei-Menüs).

Word-Protokoll

(Nur bei Geosi XL)

Anpassen der Kopf- und Fußzeilen:

In der Kopfzeile können folgende Variable verwendet werden: „[Projekt]“, „[File]“, „[ProjManager]“, „[Sachbearbeiter]“, „[Aktbezug]“, „[Kommentar]“, „[ProjStatus]“, „[Verrechnungskonto]“, „[Höhensystem]“.

Beispiel:

Word-eigene Felder in der Kopfzeile müssen in eigenen Textfeldern bzw. Positionsrahmen stehen (ebenso Formatierungen, die nicht für die gesamte Zeile gelten…).

Anpassen des Deckblattes

Die Gestaltung des Deckblattes erfolgt über Word eigene Dokumentvariable. Folgende Variable werden mit Werten versorgt: „Projekt“, „File“, „ProjManager“, „Sachbearbeiter“, „Aktbezug“, „Kommentar“, „ProjStatus“, „Verrechnungskonto“

Einfügen einer Dokumentvariable im Word:

1) „Einfügen“, „Feld“, „DocVariable“  -> es wird das Feld mit dem Text Fehler! Dokumentvariable nicht definiert erscheinen.
2) Rechte Maustaste, Menüpunkt „Feldfunktionen ein/aus“ -> es wird die Formel der Variable angezeigt  ( wahrscheinlich: DOCVARIABLE  \* MERGEFORMAT })
3) Inhalt des Feldes auf { DOCVARIABLE  “Projekt“ } ändern.

Schlagen  Sie  bearbeiten